Monday, May 4, 2009

Set up NAT on NetBSD

In order to enable packet forwarding, you should add this to /etc/sysctl.conf:

sysctl -w net.inet.ip.forwarding=1
(or enable ip forwarding when compiling the kernel)

Then, add this line to /etc/ipnat.conf:

map re0 192.168.1.0/24 -> 0/32
re0 is the name of your external etherned card.
Also, do not forget to add ipnat="YES" to your /etc/rc.conf.

Sunday, May 3, 2009

The Flag

"flag" will be the name of my frontend to pkgsrc, very soon..

Saturday, May 2, 2009

Bespin

hmm, playframework with Bespin http://tinyurl.com/csxgvb , couldn't it exist before Bespin?

Automated testing in NetBSD 5.0

With the release of NetBSD 5.0, a new testing infrastructure for the operating system will get wide exposure. This testing infrastructure is based on the Automated Testing Framework (ATF), a project that was started as part of the Google Summer of Code 2007 program, and that provides a platform-independent framework to easily write and automatically exercise test cases. As of this release, only a few NetBSD-specific tests are available as ATF-based tests, but they are a good preview of what the future will look like.

Starting from this release, you will see a new tests.tgz distribution set during the installation of NetBSD. If you choose to install it, sysinst will populate /usr/tests with a new collection of test programs that are based on the ATF framework. Once installed, edit /etc/atf/NetBSD.conf to suit your system preferences and then, to run the tests, do:

# cd /usr/tests
# atf-run | atf-report

The whole idea of providing the test programs as an installable distribution set is that your specific combination of hardware and software is not available to system developers, so only you can make sure that the system behaves as it should. Furthermore, by successfully running the tests, you can have a good feeling that everything is working as expected!

As far as I know, there are some tests in this release that are broken, but I'm not sure if this is because the tests themselves are broken or because the features under test are broken. Help is welcome in this area!

There is still a lot of work to do in the automated testing area... but the fact that ATF is now bundled in a formal release of NetBSD raises my willingness to work on it. If only I had enough time... At the very least, expect many more ATF-based test cases in NetBSD 6.0.

http://blog.netbsd.org/tnf/entry/automated_testing_in_netbsd_5

Design by Dzelque Blogger Templates 2008

XBSD - Design by Dzelque Blogger Templates 2008